From: Paul Wassi
Date: Sun, 30 Dec 2018 20:37:50 +0000 (+0100)
Subject: ath79: fix boardname of GL.iNet GL-AR150
X-Git-Url: http://git.lede-project.org./?a=commitdiff_plain;h=8ba76d6e744f2f2fb5afb9fd8ac2b828d7c8387c;p=openwrt%2Fstaging%2Flynxis.git
ath79: fix boardname of GL.iNet GL-AR150
This device is called GL-AR150, therefore rename the board
to 'gl-ar150'
Signed-off-by: Paul Wassi
---
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 83bede0961..906ccd753f 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -89,8 +89,8 @@ ath79_setup_interfaces()
etactica,eg200)
ucidef_set_interface_lan "eth0" "dhcp"
;;
- glinet,ar150|\
glinet,ar300m|\
+ glinet,gl-ar150|\
glinet,gl-x750)
ucidef_set_interfaces_lan_wan "eth1" "eth0"
;;
diff --git a/target/linux/ath79/dts/ar9330_glinet_ar150.dts b/target/linux/ath79/dts/ar9330_glinet_ar150.dts
deleted file mode 100644
index fbc3acdd1b..0000000000
--- a/target/linux/ath79/dts/ar9330_glinet_ar150.dts
+++ /dev/null
@@ -1,145 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include
-#include
-
-#include "ar9330.dtsi"
-
-/ {
- model = "GL.iNet GL-AR150";
- compatible = "glinet,ar150", "qca,ar9330";
-
- aliases {
- serial0 = &uart;
- led-boot = &wlan;
- led-failsafe = &wlan;
- led-upgrade = &wlan;
- };
-
- leds {
- compatible = "gpio-leds";
-
- wlan: wlan {
- label = "gl-ar150:orange:wlan";
- gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
- linux,default-trigger = "phy0tpt";
- };
-
- lan {
- label = "gl-ar150:green:lan";
- gpios = <&gpio 13 GPIO_ACTIVE_HIGH>;
- };
-
- wan {
- label = "gl-ar150:green:wan";
- gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
- };
- };
-
- keys {
- compatible = "gpio-keys-polled";
- poll-interval = <100>;
-
- manual {
- label = "manual";
- linux,code = ;
- gpios = <&gpio 7 GPIO_ACTIVE_HIGH>;
- };
-
- auto {
- label = "auto";
- linux,code = ;
- gpios = <&gpio 8 GPIO_ACTIVE_HIGH>;
- };
-
- reset {
- label = "reset";
- linux,code = ;
- gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
- };
- };
-};
-
-&uart {
- status = "okay";
-};
-
-&gpio {
- status = "okay";
-};
-
-&usb {
- dr_mode = "host";
- status = "okay";
-};
-
-&usb_phy {
- status = "okay";
- gpios = <&gpio 6 GPIO_ACTIVE_HIGH>;
-};
-
-&spi {
- num-chipselects = <1>;
- status = "okay";
-
- flash@0 {
- compatible = "jedec,spi-nor";
- spi-max-frequency = <104000000>;
- reg = <0>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x000000 0x040000>;
- read-only;
- };
-
- partition@1 {
- label = "u-boot-env";
- reg = <0x040000 0x010000>;
- };
-
- partition@2 {
- compatible = "denx,uimage";
- label = "firmware";
- reg = <0x050000 0xfa0000>;
- };
-
- art: partition@3 {
- label = "ART";
- reg = <0xff0000 0x010000>;
- read-only;
- };
- };
- };
-};
-
-ð0 {
- status = "okay";
-
- mtd-mac-address = <&art 0x0>;
-};
-
-ð1 {
- status = "okay";
-
- mtd-mac-address = <&art 0x0>;
-
- gmac-config {
- device = <&gmac>;
-
- switch-phy-addr-swap = <0>;
- switch-phy-swap = <0>;
- };
-};
-
-&wmac {
- status = "okay";
- mtd-cal-data = <&art 0x1000>;
- mtd-mac-address = <&art 0x0>;
-};
diff --git a/target/linux/ath79/dts/ar9330_glinet_gl-ar150.dts b/target/linux/ath79/dts/ar9330_glinet_gl-ar150.dts
new file mode 100644
index 0000000000..53df36760f
--- /dev/null
+++ b/target/linux/ath79/dts/ar9330_glinet_gl-ar150.dts
@@ -0,0 +1,145 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include
+#include
+
+#include "ar9330.dtsi"
+
+/ {
+ model = "GL.iNet GL-AR150";
+ compatible = "glinet,gl-ar150", "qca,ar9330";
+
+ aliases {
+ serial0 = &uart;
+ led-boot = &wlan;
+ led-failsafe = &wlan;
+ led-upgrade = &wlan;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ wlan: wlan {
+ label = "gl-ar150:orange:wlan";
+ gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ lan {
+ label = "gl-ar150:green:lan";
+ gpios = <&gpio 13 GPIO_ACTIVE_HIGH>;
+ };
+
+ wan {
+ label = "gl-ar150:green:wan";
+ gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <100>;
+
+ manual {
+ label = "manual";
+ linux,code = ;
+ gpios = <&gpio 7 GPIO_ACTIVE_HIGH>;
+ };
+
+ auto {
+ label = "auto";
+ linux,code = ;
+ gpios = <&gpio 8 GPIO_ACTIVE_HIGH>;
+ };
+
+ reset {
+ label = "reset";
+ linux,code = ;
+ gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+ };
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&gpio {
+ status = "okay";
+};
+
+&usb {
+ dr_mode = "host";
+ status = "okay";
+};
+
+&usb_phy {
+ status = "okay";
+ gpios = <&gpio 6 GPIO_ACTIVE_HIGH>;
+};
+
+&spi {
+ num-chipselects = <1>;
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ spi-max-frequency = <104000000>;
+ reg = <0>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@1 {
+ label = "u-boot-env";
+ reg = <0x040000 0x010000>;
+ };
+
+ partition@2 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x050000 0xfa0000>;
+ };
+
+ art: partition@3 {
+ label = "ART";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+ð0 {
+ status = "okay";
+
+ mtd-mac-address = <&art 0x0>;
+};
+
+ð1 {
+ status = "okay";
+
+ mtd-mac-address = <&art 0x0>;
+
+ gmac-config {
+ device = <&gmac>;
+
+ switch-phy-addr-swap = <0>;
+ switch-phy-swap = <0>;
+ };
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&art 0x0>;
+};
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 31c62f659d..600ab43e7f 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -259,14 +259,14 @@ define Device/etactica_eg200
endef
TARGET_DEVICES += etactica_eg200
-define Device/glinet_ar150
+define Device/glinet_gl-ar150
ATH_SOC := ar9330
DEVICE_TITLE := GL.iNet GL-AR150
DEVICE_PACKAGES := kmod-usb-chipidea2
IMAGE_SIZE := 16000k
SUPPORTED_DEVICES += gl-ar150
endef
-TARGET_DEVICES += glinet_ar150
+TARGET_DEVICES += glinet_gl-ar150
define Device/glinet_ar300m-nor
ATH_SOC := qca9531