projects
/
openwrt
/
staging
/
jogo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
629e653
)
build: warn when packages have no associated install section
testing
author
Jonas Gorski
<jonas.gorski@gmail.com>
Sat, 22 Jun 2019 12:02:27 +0000
(14:02 +0200)
committer
Jonas Gorski
<jonas.gorski@gmail.com>
Sat, 22 Jun 2019 12:05:45 +0000
(14:05 +0200)
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
include/package-ipkg.mk
patch
|
blob
|
history
diff --git
a/include/package-ipkg.mk
b/include/package-ipkg.mk
index 38252b95cdb92ae788e0b6f326ae28b77ed272a2..442d3854f046f5795e24d6ad7c5031b083f9e54f 100644
(file)
--- a/
include/package-ipkg.mk
+++ b/
include/package-ipkg.mk
@@
-124,6
+124,8
@@
ifeq ($(DUMP),)
endif
$(PKG_INSTALL_STAMP).$(1): prepare-package-install
echo "$(1)" >> $(PKG_INSTALL_STAMP)
+ else
+ $(if $(CONFIG_PACKAGE_$(1)),$$(warning WARNING: skipping $(1) -- package has no install section))
endif
endif