ucode: update to Git HEAD (2024-07-11) openwrt-23.05
authorJo-Philipp Wich <jo@mein.io>
Thu, 11 Jul 2024 22:21:03 +0000 (00:21 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 11 Jul 2024 22:27:14 +0000 (00:27 +0200)
96f74b5be829 ubus: make ubus_context first in uc_ubus_connection_t
7e5830edfb38 nl80211: fix datatype of NL80211_BAND_IFTYPE_ATTR_HE_CAP_{MAC,PHY} attrs
5c8fd34bac42 nl80211: fix parsing of NL80211_BAND_ATTR_VHT_MCS_SET attribute
e8d4e4fe967d nl80211: fix decoding of NL80211_BAND_IFTYPE_ATTR_HE_CAP_MCS_SET attribute
30a3f7ad0433 rtnl: store callback in listener registry only on success
9cbe8294909f rtnl: optimize reception of rtnl events
534417132e18 rtnl: increase event socket rx buffer size limit to 1 MiB
3f9811d2f7b7 compiler: close upvalues on loop control statements
ee4af9b55cb4 vm: rework object iteration
a275399dd8e2 uci: refactor uci.changes() to match documentation
1220992631d5 ubus: automatically clear error information
d6fd94014eea uci: automatically clear error information
99837f280b61 uloop: automatically clear error information
ba3855ae3775 lib: fix documentation typo for `pop()` function
be767ae197ba vm: rework `in` operator semantics
4ade84e8fb81 ubus: add explicit support for deferring incoming requests
cfe137be068a uci: remove incorrectly documentated reorder() parameter
e8d78a26da0c lib: introduce socket library
a0ad1d127ae6 build: fix symbol and library detection
674f65ee551d jsdoc: disable default module titles
a33d16a86493 socket: rework error handling
e2b81d869222 uloop: add documentation
953f36c96e8a socket: make socket.send() accept non-string data
f211d5ac666f ubus: fix uc_ubus_have_uloop for eloop+uloop combination
0662de64bd1f socket: add AF_PACKET socket type support
b594ff8a2841 socket: remove leftover debug code
0d823e702bfe socket: fix addrinfo() with omitted service argument
8cf816d615fd socket: fix potential memory leak in connect()
8f5f231d66cd socket: optimize poll() argument handling
36f106056069 socket: remove wrong documentation fragment
525fca224012 socket: uv_to_sockaddr(): fix length calculation for AF_UNIX addresses
3938645ad9e3 socket: support IPv6 addresses in struct conversion routines
3a586dc7ddbe socket: improve uc_socket_connect() behavior
7b269f1cd3d2 socket: improve uc_socket_listen() behavior
fc6f2b89febf socket: handle further socket option value types
d6f25797dad1 socket: add IPv6 socket options
7611487b9a05 socket: implement recvmsg(), sendmsg() and cmsg support
d2e44bfa8b54 core-lib: improved documentation
e0bab40c8578 fs: add truncate() file method
5d305cfb2ab7 fs: add lock() file method
8b0318f7fabe lib: introduce zlib library
73644a036f5a nl80211: move access to tb array out of uc_nl_convert_attr and below
6e3cf83a77a7 nl80211: add support for multi-attribute arrays
6ff24d5488a9 nl80211: update nl80211.h to latest wireless-next
abc2aef28641 nl80211: add wiphy multi-radio support
115a84fa3c13 nl80211: gracefully handle illegal netlink error code
f6ea6fc8f026 nl80211: support conversion from/to struct array attributes
f5b5a5835965 nl80211: drop unused structure members from connection context
bc13278eae5e nl80211: support the MAC80211_HWSIM netlink protocol family

Fixes: https://github.com/jow-/ucode/issues/186
Fixes: https://github.com/jow-/ucode/issues/187
Fixes: https://github.com/jow-/ucode/issues/188
Fixes: https://github.com/jow-/ucode/issues/193
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/utils/ucode/Makefile

index c1fadd817a44688d172dc64f39e2a9e948c5995b..a35a36d7c23cbb6c719abc144ef5a4e5ddb49826 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2023-11-07
-PKG_SOURCE_VERSION:=a6e75e02528e36f3610a7f0073453018336def2e
-PKG_MIRROR_HASH:=e1a0f98ba865ed5911d5db3bfca55a2f1b825992bf5f7c7e324928d9412d7ae2
+PKG_SOURCE_DATE:=2024-07-11
+PKG_SOURCE_VERSION:=b391fd7a77f5cb6fd34650dc7a90bb4f8c120131
+PKG_MIRROR_HASH:=5079c86e1f7fb8c2944cdd1f72bf793678949eafd38ee2ed93e462d65bd658fa
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC
 
@@ -43,12 +43,14 @@ CMAKE_HOST_OPTIONS += \
        -DNL80211_SUPPORT=OFF \
        -DRESOLV_SUPPORT=OFF \
        -DRTNL_SUPPORT=OFF \
+       -DSOCKET_SUPPORT=OFF \
        -DSTRUCT_SUPPORT=ON \
        -DUBUS_SUPPORT=OFF \
        -DUCI_SUPPORT=OFF \
        -DULOOP_SUPPORT=OFF \
        -DDEBUG_SUPPORT=ON \
-       -DLOG_SUPPORT=OFF
+       -DLOG_SUPPORT=OFF \
+       -DZLIB_SUPPORT=OFF
 
 
 define Package/ucode/default
@@ -155,6 +157,10 @@ $(eval $(call UcodeModule, \
        rtnl, RTNL_SUPPORT, +libnl-tiny +libubox, \
        The rtnl plugin provides access to the Linux routing netlink API.))
 
+$(eval $(call UcodeModule, \
+       struct, SOCKET_SUPPORT, , \
+       The socket plugin provides access to IPv4, IPv6, Unix and packet socket APIs.))
+
 $(eval $(call UcodeModule, \
        struct, STRUCT_SUPPORT, , \
        The struct plugin implements Python 3 compatible struct.pack/unpack functionality.))
@@ -171,6 +177,10 @@ $(eval $(call UcodeModule, \
        uloop, ULOOP_SUPPORT, +libubox, \
        The uloop module allows ucode scripts to interact with OpenWrt uloop event loop implementation.))
 
+$(eval $(call UcodeModule, \
+       zlib, ZLIB_SUPPORT, +zlib, \
+       The zlib module exposes the Zlib deflate and inflate APIs.))
+
 $(eval $(call BuildPackage,libucode))
 $(eval $(call BuildPackage,ucode))