projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6b0c658
)
package/strace: don't link against libdw (debug symbols)
coverity
author
Alexander Couzens
<lynxis@fe80.eu>
Tue, 4 Sep 2018 01:10:24 +0000
(
03:10
+0200)
committer
Alexander Couzens
<lynxis@fe80.eu>
Tue, 4 Sep 2018 08:36:43 +0000
(10:36 +0200)
libdw is not a dependency of strace. The build will fail
if strace will link unexpected against it.
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/devel/strace/Makefile
patch
|
blob
|
history
diff --git
a/package/devel/strace/Makefile
b/package/devel/strace/Makefile
index 3704aa8b150db3634989f43b5ac88885c9d7f511..71d4476df6d2af9baa9cb6144bf4189a8b7eda57 100644
(file)
--- a/
package/devel/strace/Makefile
+++ b/
package/devel/strace/Makefile
@@
-55,7
+55,9
@@
config PACKAGE_strace_libunwind
default n
endef
-CONFIGURE_ARGS += --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+CONFIGURE_ARGS += \
+ --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no) \
+ --with-libdw=no
MAKE_FLAGS := \
CCOPT="$(TARGET_CFLAGS)"