projects
/
openwrt
/
staging
/
kaloz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6aa8c5d
)
fix madwifi hal target for mips*
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 30 Aug 2008 09:59:00 +0000
(09:59 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 30 Aug 2008 09:59:00 +0000
(09:59 +0000)
SVN-Revision: 12435
package/madwifi/Makefile
patch
|
blob
|
history
diff --git
a/package/madwifi/Makefile
b/package/madwifi/Makefile
index 699a4afd0a39547fd1f4ad733e00f34c798d4a60..adfd418b20b606fcbcfc74135acf204ef2ed51a0 100644
(file)
--- a/
package/madwifi/Makefile
+++ b/
package/madwifi/Makefile
@@
-54,11
+54,20
@@
ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
BUS:=
endif
-ifeq ($(ARCH),mips)
- HAL_TARGET:=mips-be-elf
-endif
-ifeq ($(ARCH),mipsel)
- HAL_TARGET:=mips-le-elf
+ifneq ($(CONFIG_CPU_MIPS32_R2),)
+ ifeq ($(ARCH),mips)
+ HAL_TARGET:=mips32r2-be-elf
+ endif
+ ifeq ($(ARCH),mipsel)
+ HAL_TARGET:=mips32r2-le-elf
+ endif
+else
+ ifeq ($(ARCH),mips)
+ HAL_TARGET:=mips32-be-elf
+ endif
+ ifeq ($(ARCH),mipsel)
+ HAL_TARGET:=mips32-le-elf
+ endif
endif
ifeq ($(ARCH),i386)
HAL_TARGET:=i386-elf