projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c07fdec
)
ar71xx: create smaller sysupgrade files for the TP-Link boards
author
Gabor Juhos
<juhosg@openwrt.org>
Wed, 10 Mar 2010 17:41:52 +0000
(17:41 +0000)
committer
Gabor Juhos
<juhosg@openwrt.org>
Wed, 10 Mar 2010 17:41:52 +0000
(17:41 +0000)
SVN-Revision: 20121
target/linux/ar71xx/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ar71xx/image/Makefile
b/target/linux/ar71xx/image/Makefile
index b16ee5dac2b9c81c6f4018ab5a7c49ae0db1fda7..2f990da080174177700ec8e88e8b122d33a1911d 100644
(file)
--- a/
target/linux/ar71xx/image/Makefile
+++ b/
target/linux/ar71xx/image/Makefile
@@
-270,7
+270,12
@@
define Image/Build/TPLINK
-B $(4) -N OpenWrt -V $(REVISION)\
-k $(KDIR)/vmlinux-$(2).bin.gz \
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
- -o $(call imgname,$(1),$(2))-universal.bin
+ -o $(call imgname,$(1),$(2))-factory.bin
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -B $(4) -N OpenWrt -V $(REVISION) -s \
+ -k $(KDIR)/vmlinux-$(2).bin.gz \
+ -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ -o $(call imgname,$(1),$(2))-sysupgrade.bin
endef
define Image/Build/TPLINK/initramfs