valgrind: Fix build on ARMv7
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 7 Oct 2024 21:28:20 +0000 (23:28 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 8 Oct 2024 20:23:11 +0000 (22:23 +0200)
The valgrind configure script checks if host_cpu is set to armv7 or arm.
By default --host is set to arm-openwrt-linux and the host_cpu variable
is set to arm. Then the valgrind build tries to compile valgrind for
armv6 and fails. Set it explicitly to armv7 to compile valgrind with
armv7 support.

Fixes: 1a55d90320c1 ("valgrind: Update to version 3.23")
Link: https://github.com/openwrt/openwrt/pull/16633
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/devel/valgrind/Makefile

index a8e47db7c883f30890d850b1a090e3d8c1ee6238..f2fa400444f655a7a5702809005e94849511ba4d 100644 (file)
@@ -97,6 +97,10 @@ else
        BITS := 32bit
 endif
 
+ifeq ($(CONFIG_arm_v7),y)
+       CONFIGURE_ARGS += --host=armv7-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX))
+endif
+
 CONFIGURE_ARGS += \
        --enable-lto \
        --enable-tls \