projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1df0179
)
kernel: add new core sound module snd-pcm-dmaengine.ko for 3.12 kernels and above
author
Zoltan Herpai
<wigyori@uid0.hu>
Tue, 12 Nov 2013 01:09:15 +0000
(
01:09
+0000)
committer
Zoltan Herpai
<wigyori@uid0.hu>
Tue, 12 Nov 2013 01:09:15 +0000
(
01:09
+0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
SVN-Revision: 38772
package/kernel/linux/modules/sound.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/sound.mk
b/package/kernel/linux/modules/sound.mk
index 28b989063fb28f0936da3d38a4126d9875519c8e..4e1a656dd2707286677786ec2485bce05787e4b6 100644
(file)
--- a/
package/kernel/linux/modules/sound.mk
+++ b/
package/kernel/linux/modules/sound.mk
@@
-40,6
+40,14
@@
SOUNDCORE_FILES += \
$(LINUX_DIR)/sound/core/snd-compress.ko
endif
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
+SOUNDCORE_LOAD += \
+ snd-pcm-dmaengine
+
+SOUNDCORE_FILES += \
+ $(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko
+endif
+
define KernelPackage/sound-core
SUBMENU:=$(SOUND_MENU)
TITLE:=Sound support