xdp-tools: fix compilation when bpftool is installed
authorTil Kaiser <mail@tk154.de>
Sun, 27 Oct 2024 13:02:14 +0000 (14:02 +0100)
committerRobert Marko <robimarko@gmail.com>
Mon, 28 Oct 2024 09:34:50 +0000 (10:34 +0100)
Currently, xdp-tools doesn't compile on build systems where
bpftool is installed because additional tools and BPF programs
will be compiled then, which results in build errors.

This commit disables the compilation of those bpftool-dependent tools.

Signed-off-by: Til Kaiser <mail@tk154.de>
Link: https://github.com/openwrt/openwrt/pull/16787
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/network/utils/xdp-tools/Makefile

index 8c4071991fd2c3340f5dfe63494df5a4e6c01de8..8bce10f634a795c3c78efbb89a410bb94a54f93b 100644 (file)
@@ -87,7 +87,8 @@ CONFIGURE_VARS += \
        CLANG="$(CLANG)" \
        BPF_TARGET="$(BPF_ARCH)-linux-gnu" \
        LLC="$(LLVM_LLC)" \
-       BPF_LDFLAGS="-march=$(BPF_TARGET) -mcpu=v3"
+       BPF_LDFLAGS="-march=$(BPF_TARGET) -mcpu=v3" \
+       BPFTOOL=""
 
 ifneq ($(findstring s,$(OPENWRT_VERBOSE)),)
        MAKE_FLAGS+=V=1