projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f0146de
)
[packages] strace: only change CPPFLAGS when building with an external toolchain...
author
Nicolas Thill
<nico@openwrt.org>
Sat, 17 Apr 2010 19:06:42 +0000
(19:06 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Sat, 17 Apr 2010 19:06:42 +0000
(19:06 +0000)
SVN-Revision: 20961
utils/strace/Makefile
patch
|
blob
|
history
diff --git
a/utils/strace/Makefile
b/utils/strace/Makefile
index 5b096d2fcb189f60c4446bc21b1a3bf049cdc69e..c1112d8aea1ffed445a4a769ff0d2e83c810c90d 100644
(file)
--- a/
utils/strace/Makefile
+++ b/
utils/strace/Makefile
@@
-44,9
+44,9
@@
endef
CONFIGURE_VARS += \
ac_cv_header_linux_netlink_h=yes
-# needed when compiling with an external toolchain
-TARGET_CFLAGS += \
- -I$(LINUX_DIR)/include
+ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+ TARGET_CPPFLAGS += -I$(LINUX_DIR)/include
+endif
MAKE_FLAGS := \
CCOPT="$(TARGET_CFLAGS)"