projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7ef7dba
)
pcre: add host variant of libpcre
author
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Tue, 14 Jul 2020 21:32:28 +0000
(16:32 -0500)
committer
Daniel Golle
<daniel@makrotopia.org>
Fri, 14 Aug 2020 01:29:03 +0000
(
02:29
+0100)
This is needed to build the host variant of libselinux.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libs/pcre/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/pcre/Makefile
b/package/libs/pcre/Makefile
index b638c876da88904d775149a9ee3116673706bd8b..36556141693b83efa747ef0326ae1a128e0b75ea 100644
(file)
--- a/
package/libs/pcre/Makefile
+++ b/
package/libs/pcre/Makefile
@@
-61,6
+61,18
@@
define Package/libpcrecpp
DEPENDS:=+libpcre $(CXX_DEPENDS)
endef
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --enable-utf8 \
+ --enable-unicode-properties \
+ --enable-pcre16 \
+ --with-match-limit-recursion=16000 \
+ --enable-cpp
+
+$(eval $(call HostBuild))
+
+
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \