uboot-laniq: fix compilation with GCC14
authorRosen Penev <rosenp@gmail.com>
Tue, 3 Sep 2024 21:21:29 +0000 (14:21 -0700)
committerRobert Marko <robimarko@gmail.com>
Sun, 8 Sep 2024 09:49:20 +0000 (11:49 +0200)
GCC errors on returning int in void function now.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16348
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/boot/uboot-lantiq/Makefile
package/boot/uboot-lantiq/patches/0112-MIPS-add-board-support-for-Arcadyan-VGV7510KW22.patch
package/boot/uboot-lantiq/patches/0116-MIPS-add-board-support-for-BT-Home-Hub-5A.patch

index b569232b3dd85036c119ab2927551ce3f9e0b19d..efee4507e5b3aa48578c3c938fae06d36d746331 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
 PKG_VERSION:=2013.10
-PKG_RELEASE:=66
+PKG_RELEASE:=67
 
 PKG_HASH:=0d71e62beb952b41ebafb20a7ee4df2f960db64c31b054721ceb79ff14014c55
 
index 39499fcebcfa9b2f9d6dd24b83a6cb6eb6c6db34..3f3424da6ff88cb9d050035c3174880f03fe3361 100644 (file)
@@ -95,7 +95,7 @@
 +void show_boot_progress(int arg)
 +{
 +      if (!do_gpio_init)
-+              return 0;
++              return;
 +
 +      if (arg >= 0) {
 +              /* Success - turn off the red power LED and turn on the green power LED */
 +              gpio_set_value(GPIO_POWER_RED, 0);
 +      }
 +
-+      return 0;
++      return;
 +}
 +
 +static const struct ltq_eth_port_config eth_port_config[] = {
index fd709bc2acd2a8909350850a78899047a9d8584b..992236cded5671591d5f751e82bbb4da2b7105bf 100644 (file)
 +void show_boot_progress(int arg)
 +{
 +      if (!do_gpio_init)
-+              return 0;
++              return;
 +
 +      if (arg >= 0) {
 +              /* Success - turn off the red power LED and turn on the green power LED */
 +              gpio_set_value(GPIO_POWER_RED, 0);
 +      }
 +
-+      return 0;
++      return;
 +}
 +
 +static const struct ltq_eth_port_config eth_port_config[] = {