ipq807x: prpl haze & qnap 301w: use the standard eMMC sysupgrade code
authorRodrigo Balerdi <lanchon@gmail.com>
Fri, 8 Nov 2024 20:40:03 +0000 (17:40 -0300)
committerRobert Marko <robimarko@gmail.com>
Sun, 17 Nov 2024 11:24:43 +0000 (12:24 +0100)
Note that the old ad-hoc method did not explicitly align backup data
to 64 KiB boundaries.

Also note that the qnap 301w has a 'rootfs_data' partition in the eMMC
that is being ignored by fstools during boot, presumably due to a bug.
This is why the partition is also ignored in the sysupgrade code and
there is no definition of CI_DATAPART="rootfs_data".

Signed-off-by: Rodrigo Balerdi <lanchon@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16505
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/qualcommax/image/ipq807x.mk
target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh

index 401f455585d4e5da1087df19ebe6e4deba82e9f6..60af8654593a4664d726cb09b3d4cb07e4fafcfb 100644 (file)
@@ -308,7 +308,7 @@ define Device/prpl_haze
        DEVICE_DTS_CONFIG := config@hk09
        SOC := ipq8072
        DEVICE_PACKAGES := ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci \
-               mkf2fs f2fsck kmod-fs-f2fs kmod-leds-lp5562
+               kmod-fs-f2fs f2fs-tools kmod-leds-lp5562
 endef
 TARGET_DEVICES += prpl_haze
 
@@ -320,7 +320,7 @@ define Device/qnap_301w
        DEVICE_DTS_CONFIG := config@hk01
        KERNEL_SIZE := 16384k
        SOC := ipq8072
-       DEVICE_PACKAGES := ipq-wifi-qnap_301w
+       DEVICE_PACKAGES := kmod-fs-f2fs f2fs-tools ipq-wifi-qnap_301w
 endef
 TARGET_DEVICES += qnap_301w
 
index f822f6291df50c33ea0f9822c7a2f7de15744c58..00289dcfe6999e2d95c8dc8f0870511ba9aaf446 100644 (file)
@@ -185,9 +185,9 @@ platform_do_upgrade() {
                ;;
        prpl,haze|\
        qnap,301w)
-               kernelname="0:HLOS"
-               rootfsname="rootfs"
-               mmc_do_upgrade "$1"
+               CI_KERNPART="0:HLOS"
+               CI_ROOTPART="rootfs"
+               emmc_do_upgrade "$1"
                ;;
        tplink,eap660hd-v1)
                tplink_do_upgrade "$1"
@@ -267,6 +267,8 @@ platform_do_upgrade() {
 
 platform_copy_config() {
        case "$(board_name)" in
+       prpl,haze|\
+       qnap,301w|\
        spectrum,sax1v1k|\
        zyxel,nbg7815)
                emmc_copy_config