build: do not use shell calls to export empty opkg control files, speeds up package...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 3 Apr 2011 02:15:56 +0000 (02:15 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 3 Apr 2011 02:15:56 +0000 (02:15 +0000)
SVN-Revision: 26433

include/package-ipkg.mk

index 85f5c7c266c5e0cbb6bc00e02fe391afba6e1211..0dd398e1baa35f1a1997981857bac833dab19b8c 100644 (file)
@@ -28,8 +28,10 @@ IPKG_BUILD:= \
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
 
 define BuildIPKGVariable
+ifdef Package/$(1)/$(2)
   $(call shexport,Package/$(1)/$(2))
   $(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);
+endif
 endef
 
 PARENL :=(