projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5e239a0
)
kernel: kmod-gpio-mcp23s08 depends on i2c-core
author
Jonas Gorski
<jogo@openwrt.org>
Thu, 18 Jul 2013 20:40:15 +0000
(20:40 +0000)
committer
Jonas Gorski
<jogo@openwrt.org>
Thu, 18 Jul 2013 20:40:15 +0000
(20:40 +0000)
But only if it is selected, so make it a conditionl dependency.
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 37420
package/kernel/linux/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/other.mk
b/package/kernel/linux/modules/other.mk
index 9e97bb566f63ff014a6aba13f3cd010f525d92d1..f850581ba7d626e8dee94d14c2238d3eb7c00eac 100644
(file)
--- a/
package/kernel/linux/modules/other.mk
+++ b/
package/kernel/linux/modules/other.mk
@@
-135,7
+135,7
@@
$(eval $(call KernelPackage,gpio-dev))
define KernelPackage/gpio-mcp23s08
SUBMENU:=$(OTHER_MENU)
TITLE:=Microchip MCP23xxx I/O expander
- DEPENDS:=@GPIO_SUPPORT
+ DEPENDS:=@GPIO_SUPPORT
+PACKAGE_kmod-i2c-core:kmod-i2c-core
KCONFIG:=CONFIG_GPIO_MCP23S08
FILES:=$(LINUX_DIR)/drivers/gpio/gpio-mcp23s08.ko
AUTOLOAD:=$(call AutoLoad,40,gpio-mcp23s08)