projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3ba43e6
)
mkimage: fix spurious build errors caused by its braindead build system
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 8 Mar 2010 17:17:46 +0000
(17:17 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 8 Mar 2010 17:17:46 +0000
(17:17 +0000)
SVN-Revision: 20065
tools/mkimage/Makefile
patch
|
blob
|
history
diff --git
a/tools/mkimage/Makefile
b/tools/mkimage/Makefile
index f8d7197e13259270a19bcd2c599f5b13a116877e..c2cbb53a2d5bcf70e511906e39fa812da70c79bf 100644
(file)
--- a/
tools/mkimage/Makefile
+++ b/
tools/mkimage/Makefile
@@
-19,6
+19,7
@@
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
+ rm -f $(HOST_BUILD_DIR)/tools/.depend
touch $(HOST_BUILD_DIR)/include/config.{h,mk} $(HOST_BUILD_DIR)/include/autoconf.mk{.dep,}
$(MAKE) -C $(HOST_BUILD_DIR) SUBDIRS=tools BIN_FILES-y="mkimage" tools
endef