tools/e2fsprogs: fixup STAGING_DIR_HOST path evaluation in shell scripts
authorRobert Marko <robimarko@gmail.com>
Tue, 2 Jul 2024 09:14:17 +0000 (11:14 +0200)
committerRobert Marko <robimarko@gmail.com>
Tue, 2 Jul 2024 12:04:49 +0000 (14:04 +0200)
We have to use curly braces on the exported STAGING_DIR_HOST env variable,
instead of evaluating it directly as we are not in Make but a separate
shell script.

Otherwise it would fail with:
staging_dir/host/bin/compile_et: line 6: STAGING_DIR_HOST: command not found
staging_dir/host/bin/mk_cmds: line 5: STAGING_DIR_HOST: command not found

And so when krb5 tries to build it will fail as compile_et and mk_cmds will
return an error.

Fixes: 55bda9863dd0 ("tools/e2fsprogs: fix shell scripts under SDK")
Link: https://github.com/openwrt/openwrt/pull/15854
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/e2fsprogs/Makefile

index cb59f4d9ec7ed842b451c3f249dffe88b53f884d..2c35adfa8f9b0784ab6629c3045e37cdddd45d53 100644 (file)
@@ -39,8 +39,8 @@ endef
 
 define Host/Install
        $(call Host/Install/Default)
-       $(SED) 's|^DIR=.*|DIR=$$$$(STAGING_DIR_HOST)/share/et|' $(STAGING_DIR_HOST)/bin/compile_et
-       $(SED) 's|^DIR=.*|DIR=$$$$(STAGING_DIR_HOST)/share/ss|' $(STAGING_DIR_HOST)/bin/mk_cmds
+       $(SED) 's|^DIR=.*|DIR=$$$${STAGING_DIR_HOST}/share/et|' $(STAGING_DIR_HOST)/bin/compile_et
+       $(SED) 's|^DIR=.*|DIR=$$$${STAGING_DIR_HOST}/share/ss|' $(STAGING_DIR_HOST)/bin/mk_cmds
 endef
 
 define Host/Uninstall