ath79: update Sophos AP15 to indicate that it uses an QCA9557 SoC
authorMartin Blumenstingl <martin.blumenstingl@googlemail.com>
Sun, 11 Aug 2024 19:55:16 +0000 (21:55 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 24 Aug 2024 12:38:57 +0000 (14:38 +0200)
Device support for Sophos AP15 is based on Sophos AP55(C) and AP100(C).
Those other Sophos access points uss a QCA9558 SoC (some of them with
one of the three chains on the built-in SoC's wifi disabled) while the
AP15 uses a QCA9557 SoC (which only has two chains enabled in the
package or silicon).

This is mostly cosmetic since QCA9558 and QCA9557 are virtually
identical and all differences are automatically detected and/or managed
by the ART calibration.

Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
Link: https://github.com/openwrt/openwrt/pull/16187
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ath79/dts/qca9557_sophos_ap15.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9558_sophos_ap15.dts [deleted file]
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/dts/qca9557_sophos_ap15.dts b/target/linux/ath79/dts/qca9557_sophos_ap15.dts
new file mode 100644 (file)
index 0000000..773b423
--- /dev/null
@@ -0,0 +1,148 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca955x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       compatible = "sophos,ap15", "qca,qca9557";
+       model = "Sophos AP15";
+
+       aliases {
+               led-boot = &led_status_green;
+               led-failsafe = &led_status_yellow;
+               led-running = &led_status_green;
+               led-upgrade = &led_status_yellow;
+               label-mac-device = &eth0;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_green: status_green {
+                       function = LED_FUNCTION_STATUS;
+                       color = <LED_COLOR_ID_GREEN>;
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               led_status_yellow: status_yellow {
+                       function = LED_FUNCTION_STATUS;
+                       color = <LED_COLOR_ID_YELLOW>;
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@50000 {
+                               label = "art";
+                               reg = <0x050000 0x010000>;
+                               read-only;
+
+                               nvmem-layout {
+                                       compatible = "fixed-layout";
+                                       #address-cells = <1>;
+                                       #size-cells = <1>;
+
+                                       cal_art_1000: calibration@1000 {
+                                               reg = <0x1000 0x440>;
+                                       };
+                               };
+                       };
+
+                       partition@60000 {
+                               label = "config";
+                               reg = <0x060000 0x010000>;
+                               read-only;
+
+                               nvmem-layout {
+                                       compatible = "fixed-layout";
+                                       #address-cells = <1>;
+                                       #size-cells = <1>;
+
+                                       macaddr_config_201a: macaddr@201a {
+                                               reg = <0x201a 0x6>;
+                                       };
+                               };
+                       };
+
+                       partition@70000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x070000 0xf90000>;
+                       };
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0x10>;
+
+       phy4: ethernet-phy@4 {
+               reg = <4>;
+               eee-broken-100tx;
+               eee-broken-1000t;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       pll-data = <0xa6000000 0xa0000101 0xa0001313>;
+
+       nvmem-cells = <&macaddr_config_201a>;
+       nvmem-cell-names = "mac-address";
+
+       phy-mode = "rgmii-id";
+       phy-handle = <&phy4>;
+
+       gmac_config: gmac-config {
+               device = <&gmac>;
+
+               rgmii-enabled = <1>;
+
+               rxdv-delay = <3>;
+               rxd-delay = <3>;
+               txen-delay = <3>;
+               txd-delay = <3>;
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       nvmem-cells = <&cal_art_1000>;
+       nvmem-cell-names = "calibration";
+};
diff --git a/target/linux/ath79/dts/qca9558_sophos_ap15.dts b/target/linux/ath79/dts/qca9558_sophos_ap15.dts
deleted file mode 100644 (file)
index de54948..0000000
+++ /dev/null
@@ -1,148 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "qca955x.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/leds/common.h>
-
-/ {
-       compatible = "sophos,ap15", "qca,qca9558";
-       model = "Sophos AP15";
-
-       aliases {
-               led-boot = &led_status_green;
-               led-failsafe = &led_status_yellow;
-               led-running = &led_status_green;
-               led-upgrade = &led_status_yellow;
-               label-mac-device = &eth0;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,115200n8";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_status_green: status_green {
-                       function = LED_FUNCTION_STATUS;
-                       color = <LED_COLOR_ID_GREEN>;
-                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
-                       default-state = "on";
-               };
-
-               led_status_yellow: status_yellow {
-                       function = LED_FUNCTION_STATUS;
-                       color = <LED_COLOR_ID_YELLOW>;
-                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
-               };
-       };
-};
-
-&spi {
-       status = "okay";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x040000>;
-                               read-only;
-                       };
-
-                       partition@40000 {
-                               label = "u-boot-env";
-                               reg = <0x040000 0x010000>;
-                       };
-
-                       partition@50000 {
-                               label = "art";
-                               reg = <0x050000 0x010000>;
-                               read-only;
-
-                               nvmem-layout {
-                                       compatible = "fixed-layout";
-                                       #address-cells = <1>;
-                                       #size-cells = <1>;
-
-                                       cal_art_1000: calibration@1000 {
-                                               reg = <0x1000 0x440>;
-                                       };
-                               };
-                       };
-
-                       partition@60000 {
-                               label = "config";
-                               reg = <0x060000 0x010000>;
-                               read-only;
-
-                               nvmem-layout {
-                                       compatible = "fixed-layout";
-                                       #address-cells = <1>;
-                                       #size-cells = <1>;
-
-                                       macaddr_config_201a: macaddr@201a {
-                                               reg = <0x201a 0x6>;
-                                       };
-                               };
-                       };
-
-                       partition@70000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x070000 0xf90000>;
-                       };
-               };
-       };
-};
-
-&mdio0 {
-       status = "okay";
-
-       phy-mask = <0x10>;
-
-       phy4: ethernet-phy@4 {
-               reg = <4>;
-               eee-broken-100tx;
-               eee-broken-1000t;
-       };
-};
-
-&eth0 {
-       status = "okay";
-
-       pll-data = <0xa6000000 0xa0000101 0xa0001313>;
-
-       nvmem-cells = <&macaddr_config_201a>;
-       nvmem-cell-names = "mac-address";
-
-       phy-mode = "rgmii-id";
-       phy-handle = <&phy4>;
-
-       gmac_config: gmac-config {
-               device = <&gmac>;
-
-               rgmii-enabled = <1>;
-
-               rxdv-delay = <3>;
-               rxd-delay = <3>;
-               txen-delay = <3>;
-               txd-delay = <3>;
-       };
-};
-
-&wmac {
-       status = "okay";
-
-       nvmem-cells = <&cal_art_1000>;
-       nvmem-cell-names = "calibration";
-};
index 8bfa3599108cf4189063a848520097ea3c83fdcc..98968241e98286da5d4a2493207338d0adcc260f 100644 (file)
@@ -2913,7 +2913,7 @@ endef
 TARGET_DEVICES += sitecom_wlr-8100
 
 define Device/sophos_ap15
-  SOC := qca9558
+  SOC := qca9557
   DEVICE_VENDOR := Sophos
   DEVICE_MODEL := AP15
   IMAGE_SIZE := 15936k