merge r17580, r17581 and r17582
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2009 16:54:57 +0000 (16:54 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2009 16:54:57 +0000 (16:54 +0000)
SVN-Revision: 17583

package/base-files/Makefile
package/base-files/files/sbin/ifdown
package/firewall/Makefile
package/firewall/files/20-firewall

index ccdf9c5762593cbffeb62661c831816566fc1985..f46fe7450905d7a252a13b339ce86304b45e9b41 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=14.6
+PKG_RELEASE:=14.7
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 883f8ec42893bc8c3fb70286a6674f1430deeeac..8de414d8b6dd96ad349b52ffe97e5a398f562fc8 100755 (executable)
@@ -22,8 +22,8 @@ config_get proto "$cfg" proto
 [ -z "$proto" ] && { echo "interface not found."; exit; }
 
 config_get iface "$cfg" device
-[ "static" = "$proto" ] && {
-       env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$iface" PROTO=static /sbin/hotplug-call "iface" &
+[ "static" = "$proto" -o "none" = "$proto" ] && {
+       env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$iface" PROTO="$proto" /sbin/hotplug-call "iface"
 }
 
 # call interface stop handler
index 20bda1a475c51380ea8729d387ac8286bb5ea53b..6326fe426660e1800381d89aacbb574d2c1e95b1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=1
-PKG_RELEASE:=1.2
+PKG_RELEASE:=1.3
 
 include $(INCLUDE_DIR)/package.mk
 
index 38fbb9441877cf930c3188e467368785cde7afa5..1cfc1b9c0e266a708af2dd424fbe0b83c93e6113 100644 (file)
@@ -27,9 +27,10 @@ config_foreach load_zones zone
 }
 
 [ ifdown = "$ACTION" ] && {
+       local up
+       config_get up "$INTERFACE" up
+
        for z in $ZONE; do 
-               local up
-               config_get up $z up
                [ "$up" == "1" ] && delif "$INTERFACE" "$ifname" "$z"
        done
 }