busybox: Fix cron log level to match previous behavior
authorHannu Nyman <hannu.nyman@iki.fi>
Sun, 1 Dec 2024 11:07:05 +0000 (13:07 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 5 Dec 2024 20:16:55 +0000 (21:16 +0100)
Change the cron log level in init script from 5 to 7
in order to match previous log behavior and to avoid
log spam every minute.

Busybox cron only uses levels 5,7,8, where 5 is debug and
7 and 8 are normal logging. Use 7 as default.

(Fun note: this is needed because upstream corrected an
ancient bug in their own log level handling and now 5 actually
means something.)

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Link: https://github.com/openwrt/openwrt/pull/17107
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/utils/busybox/Makefile
package/utils/busybox/files/cron

index 7094b1e22db21201b347ffb853ccc041ad9233a2..4f155b7a2503b24fe73fe680125bafb3f01a23b2 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.37.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 4efdfa52cad32b6003c4e341148df52cc47f44ec..2ddffa61e48359e582bea396af0c519b35cb604e 100755 (executable)
@@ -28,7 +28,7 @@ start_service() {
        ln -s /etc/crontabs /var/spool/cron/ 2>/dev/null
 
        procd_open_instance
-       procd_set_param command "$PROG" -f -c /etc/crontabs -l "${loglevel:-5}"
+       procd_set_param command "$PROG" -f -c /etc/crontabs -l "${loglevel:-7}"
        for crontab in /etc/crontabs/*; do
                 procd_set_param file "$crontab"
        done