projects
/
openwrt
/
staging
/
adrian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
10aacb9
)
toolchain/gdb: fix compilation with ccache
author
Rosen Penev
<rosenp@gmail.com>
Mon, 5 Apr 2021 01:32:30 +0000
(18:32 -0700)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 17 Apr 2021 19:56:05 +0000
(21:56 +0200)
For some reason, one of the configure checks results in some infinite
loop and ends up spawning endless gcc processes, causing OOM. Just pass
a configure var to avoid it.
Same fix as
6e23813c1ed7494a9da3b5e59cfcafd71097c420
Signed-off-by: Rosen Penev <rosenp@gmail.com>
toolchain/gdb/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/gdb/Makefile
b/toolchain/gdb/Makefile
index 3bcc9d123841ce4cf7d92330bef37f6470ecb3e1..05e3c7de3c3d9fec0b0fee0891c20b25c62b35d7 100644
(file)
--- a/
toolchain/gdb/Makefile
+++ b/
toolchain/gdb/Makefile
@@
-22,6
+22,7
@@
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/toolchain-build.mk
HOST_CONFIGURE_VARS += \
+ acx_cv_cc_gcc_supports_ada=false \
gdb_cv_func_sigsetjmp=yes
HOST_CONFIGURE_ARGS = \