packages: ntfsprogs: add missing dependency - libuuid
authorJonas Gorski <jogo@openwrt.org>
Sun, 4 Aug 2013 12:03:16 +0000 (12:03 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 4 Aug 2013 12:03:16 +0000 (12:03 +0000)
This patch adds missing libuuid dependency for ntfsprogs.
Without it the package fails to install because of missing
dependency to libuuid.

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
[jogo@openwrt.org: also enable libuuid explicitly in configure]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 37677

utils/ntfsprogs/Makefile

index 78ae9f63795ef33e1ba8bcf5e528d9acee02e991..e9a976cec8df9ca8e402ac01eab210175f42f7be 100644 (file)
@@ -27,6 +27,7 @@ define Package/ntfsprogs
   CATEGORY:=Utilities
   SUBMENU:=Filesystem
   TITLE:=Linux-NTFS
+  DEPENDS:=+libuuid
   URL:=http://www.linux-ntfs.org/
   MAINTAINER:=Gianluigi Tiesi <sherpya@netfarm.it>
 endef
@@ -38,6 +39,7 @@ endef
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
+       --with-uuid \
        --disable-crypto \
        --disable-gnome-vfs \
        --disable-ntfsmount