tools: util-linux: use standard make install/uninstall
authorRobert Marko <robimarko@gmail.com>
Tue, 25 Jun 2024 15:49:43 +0000 (17:49 +0200)
committerRobert Marko <robimarko@gmail.com>
Wed, 26 Jun 2024 09:21:03 +0000 (11:21 +0200)
Instead of manually installing the binaries and removing them, we can now
simply rely on standard make install/uninstall as we are only building
tools we want to use.

This will be especially important when we start building libraries in
util-linux.

Link: https://github.com/openwrt/openwrt/pull/15806
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/util-linux/Makefile

index cede793365024f49ab4087abfc74cfa31a35a66f..cfeb858400426fbc6adde2203582fad9c545d718 100644 (file)
@@ -44,12 +44,8 @@ HOST_CONFIGURE_ARGS += \
        --without-python \
        --without-cryptsetup
 
-define Host/Install
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/hexdump $(STAGING_DIR_HOST)/bin/
-endef
-
 define Host/Uninstall
-       rm -f $(STAGING_DIR_HOST)/bin/hexdump
+       -$(call Host/Compile/Default,uninstall)
 endef
 
 $(eval $(call HostBuild))