optee-os-stm32: add OP-TEE for stm32 boards
authorThomas Richard <thomas.richard@bootlin.com>
Thu, 26 Sep 2024 14:19:35 +0000 (16:19 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 23 Nov 2024 14:53:21 +0000 (15:53 +0100)
Add OP-TEE for stm32 boards, with the first being STM32MP135F-DK.

Signed-off-by: Thomas Richard <thomas.richard@bootlin.com>
Link: https://github.com/openwrt/openwrt/pull/16716
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/optee-os-stm32/Makefile [new file with mode: 0644]

diff --git a/package/boot/optee-os-stm32/Makefile b/package/boot/optee-os-stm32/Makefile
new file mode 100644 (file)
index 0000000..9e68112
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2024 Bootlin
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_VERSION:=4.3.0
+PKG_RELEASE:=1
+
+PKG_HASH:=390b271905c828d6def9fa6a77bbaa425f3b434d733c8eb18f582ccbc6896096
+PKG_MAINTAINER:=Thomas Richard <thomas.richard@bootlin.com>
+
+OPTEE_USE_INTREE_DTC:=1
+
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/optee-os.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Optee-os/Default
+  BUILD_TARGET:=stm32
+endef
+
+define Optee-os/stm32mp1
+  BUILD_SUBTARGET:=stm32mp1
+  PLAT:=stm32mp1
+endef
+
+define Optee-os/stm32mp135f-dk
+  $(call Optee-os/stm32mp1)
+  NAME:=STM32MP135F-DK
+  PLAT_FLAVOR:=135F_DK
+endef
+
+OPTEE_TARGETS := stm32mp135f-dk
+
+define Package/optee-os/install/default
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(foreach img,$(OPTEE_IMAGE), \
+               $(CP) $(PKG_BUILD_DIR)/out/arm-plat-$(PLAT)/core/$(img) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(img); \
+       )
+endef
+
+$(eval $(call BuildPackage/Optee-os))