linux: package qemu-fw-cfg driver
authorJo-Philipp Wich <jo@mein.io>
Fri, 21 Jun 2024 08:41:19 +0000 (10:41 +0200)
committerJo-Philipp Wich <jo@mein.io>
Sun, 26 Jan 2025 13:06:40 +0000 (14:06 +0100)
Add the necessary definitions to package the kernel module for QEMU firmware
configuration (fw_cfg) entries.

This module exposes parameters passed via the QEMU `-fw_cfg` command line
option to the guest system within the `/sys/firmware/qemu_fw_cfg/` directory
in a similar fashion to UEFI variables in sysfs.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/kernel/linux/modules/other.mk

index 7b64985fd69e7df95d2f19822cb3c8e4106dd267..1aaa2d79cb013333683efdf173274258e8c50be0 100644 (file)
@@ -1152,3 +1152,19 @@ define KernelPackage/mhi-pci-generic/description
 endef
 
 $(eval $(call KernelPackage,mhi-pci-generic))
+
+define KernelPackage/qemu-fw-cfg
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=QEMU fw_cfg device support
+  KCONFIG:=CONFIG_FW_CFG_SYSFS \
+           CONFIG_FW_CFG_SYSFS_CMDLINE=y
+  FILES:=$(LINUX_DIR)/drivers/firmware/qemu_fw_cfg.ko
+  AUTOLOAD:=$(call AutoProbe,qemu_fw_cfg)
+endef
+
+define KernelPackage/qemu-fw-cfg/description
+  Kernel module for exposing QEMU firmware configuration (fw_cfg) values
+  via sysfs in /sys/firmware/fw_cfg.
+endef
+
+$(eval $(call KernelPackage,qemu-fw-cfg))