kbuild: update comments in scripts/Makefile.modpost
authorMasahiro Yamada <yamada.masahiro@socionext.com>
Wed, 6 Nov 2019 14:52:15 +0000 (23:52 +0900)
committerMasahiro Yamada <yamada.masahiro@socionext.com>
Mon, 11 Nov 2019 11:07:03 +0000 (20:07 +0900)
The comment line "When building external modules ..." explains
the same thing as "Include the module's Makefile ..." a few lines
below.

The comment "they may be used when building the .mod.c file" is no
longer true; .mod.c file is compiled in scripts/Makefile.modfinal
since commit 9b9a3f20cbe0 ("kbuild: split final module linking out
into Makefile.modfinal"). I still keep the code in case $(obj) or
$(src) is used in the external module Makefile.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
scripts/Makefile.modpost

index 952fff4855467fb9cadeea2c767ffe902f9e9c0e..cc19b95c21167bf354d2a2655cdb89647aa5dedb 100644 (file)
@@ -67,10 +67,9 @@ __modpost:
 
 else
 
-# When building external modules load the Kbuild file to retrieve EXTRA_SYMBOLS info
 ifneq ($(KBUILD_EXTMOD),)
 
-# set src + obj - they may be used when building the .mod.c file
+# set src + obj - they may be used in the modules's Makefile
 obj := $(KBUILD_EXTMOD)
 src := $(obj)