projects
/
openwrt
/
staging
/
luka.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7640f89
)
support unpacking of .tar.xz archives, no prereq on xzcat for now
author
Jo-Philipp Wich
<jow@openwrt.org>
Fri, 6 Aug 2010 21:29:23 +0000
(21:29 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Fri, 6 Aug 2010 21:29:23 +0000
(21:29 +0000)
SVN-Revision: 22517
include/unpack.mk
patch
|
blob
|
history
diff --git
a/include/unpack.mk
b/include/unpack.mk
index 2cd17817e6929d216cf31acb1c8514848eb4ecfd..01516757771a17f40692e424b14f860781676406 100644
(file)
--- a/
include/unpack.mk
+++ b/
include/unpack.mk
@@
-32,7
+32,11
@@
ifeq ($(strip $(UNPACK_CMD)),)
EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
DECOMPRESS_CMD:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
endif
- ifeq ($(filter tgz tbz tbz2,$(EXT1)),$(EXT1))
+ ifeq ($(filter xz txz,$(EXT)),$(EXT))
+ EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
+ DECOMPRESS_CMD:=xzcat $(DL_DIR)/$(PKG_SOURCE) |
+ endif
+ ifeq ($(filter tgz tbz tbz2 txz,$(EXT1)),$(EXT1))
EXT:=tar
endif
DECOMPRESS_CMD ?= cat $(DL_DIR)/$(PKG_SOURCE) |