projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fe46689
)
image.mk: export the FILESYSTEM variable to build commands
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 3 Apr 2015 15:22:26 +0000
(15:22 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 3 Apr 2015 15:22:26 +0000
(15:22 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45251
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 8d201447fc327b63abb1f7bd602e7cecd18abda1..3ff8768a6ad49cc5f6d14b69e1c687a986b9b628 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-353,7
+353,7
@@
define Device/ExportVar
$(1) : $(2):=$$($(2))
endef
-Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL KERNEL_INITRAMFS,$(call Device/ExportVar,$(1),$(var)))
+Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL KERNEL_INITRAMFS
FILESYSTEM
,$(call Device/ExportVar,$(1),$(var)))
define Device/Check
_TARGET = $$(if $$(filter $(PROFILE),$$(PROFILES)),install,install-disabled)