compat-wireless: brcmfmac: add usb config option
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Apr 2012 22:03:15 +0000 (00:03 +0200)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Mon, 23 Apr 2012 23:26:27 +0000 (16:26 -0700)
This activates the usb part of brcmfmac.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
config.mk

index 012a59fa4e46b9eed1755cc106b77a21bfb933a0..d2373b948e9a2e138fdc7118c5f5add7ddb38fbc 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -502,6 +502,8 @@ export CONFIG_COMPAT_USB_URB_THREAD_FIX=y
 export CONFIG_ATH9K_HTC=m
 # export CONFIG_ATH9K_HTC_DEBUGFS=y
 
+export CONFIG_BRCMFMAC_USB=y
+
 # RT2500USB does not require firmware
 export CONFIG_RT2500USB=m
 ifdef CONFIG_CRC_CCITT
@@ -591,10 +593,7 @@ export CONFIG_ATH6KL=m
 # export CONFIG_ATH6KL_DEBUG=y
 endif #CONFIG_COMPAT_KERNEL_2_6_27
 
-ifndef CONFIG_COMPAT_KERNEL_2_6_29
-export CONFIG_BRCMFMAC=m
 export CONFIG_BRCMFMAC_SDIO=y
-endif #CONFIG_COMPAT_KERNEL_2_6_29
 
 endif #CONFIG_MMC
 
@@ -633,6 +632,10 @@ export CONFIG_ATH_COMMON=m
 export CONFIG_BRCMUTIL=m
 # export CONFIG_BRCMDBG=y
 
+ifndef CONFIG_COMPAT_KERNEL_2_6_29
+export CONFIG_BRCMFMAC=m
+endif #CONFIG_COMPAT_KERNEL_2_6_29
+
 export CONFIG_WL_TI=y
 export CONFIG_WLCORE=m