projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
aae0edf
)
kernel: crypto: fix depends in kmod-crypto-hmac
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 9 Aug 2015 17:18:10 +0000
(17:18 +0000)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 9 Aug 2015 17:18:10 +0000
(17:18 +0000)
This module had two depends lines.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 46576
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index d530b1471a72394c071536f1d93774040a54118d..2e245e37a9db7897a88aa0716fef835020e96d87 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-380,10
+380,9
@@
$(eval $(call KernelPackage,crypto-ecb))
define KernelPackage/crypto-hmac
TITLE:=HMAC digest CryptoAPI module
- DEPENDS:=+kmod-crypto-hash
+ DEPENDS:=+kmod-crypto-hash
+kmod-crypto-manager
KCONFIG:=CONFIG_CRYPTO_HMAC
FILES:=$(LINUX_DIR)/crypto/hmac.ko
- DEPENDS:=+kmod-crypto-manager
AUTOLOAD:=$(call AutoLoad,09,hmac)
$(call AddDepends/crypto)
endef