update to dhcpd 3.1.0 and change bootup option to be quiet (not display the copyright...
authorTim Yardley <lst@openwrt.org>
Tue, 8 Jan 2008 17:07:25 +0000 (17:07 +0000)
committerTim Yardley <lst@openwrt.org>
Tue, 8 Jan 2008 17:07:25 +0000 (17:07 +0000)
SVN-Revision: 10143

net/dhcp/Makefile
net/dhcp/files/dhcpd.init

index c9699932bfb526c4cb380c2003ee3957b6545bd0..f63c7ae13013190cc080f5fa88338231bb6ffd62 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dhcp
-PKG_VERSION:=3.0.6
+PKG_VERSION:=3.1.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/
-PKG_MD5SUM:=724bad21ad8b638abadd5fcc07df1a0f
+PKG_MD5SUM:=27d179a3c3fbef576566b456a1168246
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -44,17 +44,16 @@ define Build/Configure
        (cd $(PKG_BUILD_DIR) ; \
                UNAME_S=Linux \
                UNAME_M=$(ARCH) \
-               UNAME_R=2.4.34 \
+               UNAME_R=2.6.23 \
                ./configure \
                        --copts "$(TARGET_CFLAGS)" \
-                       linux-2.2 \
        );
 endef
 
 define Build/Compile
        UNAME_S=Linux \
        UNAME_M=$(ARCH) \
-       UNAME_R=2.4.34 \
+       UNAME_R=2.6.23 \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
index 25f846645b8179c7e70ba6ca0f05b9b582238fe7..15159bb8e3a8ee332fae91d5c0bada204af4c2d0 100644 (file)
@@ -13,7 +13,7 @@ start() {
                touch $lease_file
        fi
        
-       /usr/sbin/dhcpd -cf $config_file -lf $lease_file
+       /usr/sbin/dhcpd -q -cf $config_file -lf $lease_file
        
        if [ $$ -eq 0 ]; then
                echo "  isc-dhcpd failed to start"