kernel: r8125: disable ASPM
authorPavel Kubelun <be.dissent@gmail.com>
Wed, 16 Apr 2025 18:07:32 +0000 (21:07 +0300)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Wed, 23 Apr 2025 07:27:49 +0000 (09:27 +0200)
Disable ASPM support for this NIC, fixing strange behavior problems, such as
increased latency, strange uneven throughput, etc.
With this option disabled the NIC achieves stable performance.
Upsteam r8169 driver disables ASPM by default for this NIC.

Signed-off-by: Pavel Kubelun <be.dissent@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/18509
[bump release, fix commit description, split 2nd tx queue part]
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
package/kernel/r8125/Makefile

index 9dde19437ad9fbabdc89d58ec6ee16de69d421d2..6a97143e1706d39a230cd4f9b03ee2ffc5fddb4c 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=r8125
 PKG_VERSION:=9.015.00
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://github.com/openwrt/rtl8125/releases/download/$(PKG_VERSION)
@@ -23,6 +23,7 @@ define KernelPackage/r8125
   AUTOLOAD:=$(call AutoProbe,r8125,1)
   PROVIDES:=kmod-r8169
   VARIANT:=regular
+  PKG_MAKE_FLAGS += CONFIG_ASPM=n
 endef
 
 define KernelPackage/r8125-rss