trusted-firmware-a.mk: fix release download URL
authorChukun Pan <amadeus@jmu.edu.cn>
Fri, 20 Dec 2024 14:30:01 +0000 (22:30 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 1 Jan 2025 22:14:31 +0000 (23:14 +0100)
The URL of trusted-firmware-a is no longer available for
downloading release:
https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/
curl: (22) The requested URL returned error: 401 Unauthorized

So we switch to the GitHub mirror repository to download.

Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Link: https://github.com/openwrt/openwrt/pull/17360
Signed-off-by: Robert Marko <robimarko@gmail.com>
(cherry picked from commit 4b6eb631e18b3ccccada91d5bccbb684e6ccc5a4)

include/trusted-firmware-a.mk

index e469dae9840087f2fe6c237efc1315ccebc0134b..40c9023f1def7bd29f6737b65d748534251bd66e 100644 (file)
@@ -3,7 +3,7 @@ PKG_CPE_ID ?= cpe:/a:arm:trusted_firmware-a
 
 ifndef PKG_SOURCE_PROTO
 PKG_SOURCE = trusted-firmware-a-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/snapshot
+PKG_SOURCE_URL:=https://codeload.github.com/TrustedFirmware-A/trusted-firmware-a/tar.gz/v$(PKG_VERSION)?
 endif
 
 PKG_BUILD_DIR = $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)