projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
93cc4f7
)
kernel: modules: video: fix drm-imx for 6.1
author
Tim Harvey
<tharvey@gateworks.com>
Thu, 18 Jan 2024 22:40:34 +0000
(14:40 -0800)
committer
Christian Marangi
<ansuelsmth@gmail.com>
Fri, 2 Feb 2024 16:31:44 +0000
(17:31 +0100)
Linux 6.1 changed DRM_GEM_DMA_HELPER to a module (drm_dma_helper.ko).
Add this to the drm-imx to fix module dependencies.
Signed-off-by: Tim Harvey <tharvey@gateworks.com>
package/kernel/linux/modules/video.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/video.mk
b/package/kernel/linux/modules/video.mk
index 7ff4a041aea12a7d94a80d6bcb72b731bb7e87c6..17033838ebdb3248571a4ba18b2f65f7a42fe977 100644
(file)
--- a/
package/kernel/linux/modules/video.mk
+++ b/
package/kernel/linux/modules/video.mk
@@
-380,6
+380,7
@@
define KernelPackage/drm-imx
CONFIG_DRM_IMX_HDMI=n
FILES:= \
$(LINUX_DIR)/drivers/gpu/drm/imx/imxdrm.ko \
+ $(LINUX_DIR)/drivers/gpu/drm/drm_dma_helper.ko@ge6.1 \
$(LINUX_DIR)/drivers/gpu/ipu-v3/imx-ipu-v3.ko
AUTOLOAD:=$(call AutoLoad,08,imxdrm imx-ipu-v3 imx-ipuv3-crtc)
endef