qualcommax: fix RAX120v2 PWM Fan controller wrong definition
authorChristian Marangi <ansuelsmth@gmail.com>
Sat, 25 May 2024 10:54:31 +0000 (12:54 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 25 Jun 2024 10:52:44 +0000 (12:52 +0200)
Fix RAX120v2 PWM Fan controller wrong definition by using a non-existant
kmod and using the wrong compatible for it enabling an external clock
while actually the device use an internal one.

Link: https://github.com/openwrt/openwrt/pull/15796
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/linux/qualcommax/files/arch/arm64/boot/dts/qcom/ipq8074-rax120v2.dts
target/linux/qualcommax/image/ipq807x.mk

index ceb47f14fdd0a26abfb6588cc4eee2dcc9c0c2a2..36e315cc8078bd92a23f72422e59880c0bef5fed 100644 (file)
        status = "okay";
 
        g761@3e {
-               compatible = "gmt,g763";
+               compatible = "gmt,g761";
                reg = <0x3e>;
-               clocks =<&sleep_clk>;
                fan_gear_mode = <0>;
                fan_start = <1>;
                pwm_polarity = <0>;
index b305c9dbaaa26f1feec275095d0cfc7351298be8..d75cf3dd3cc3431e93079cb82581bb5a0c53383e 100644 (file)
@@ -161,7 +161,7 @@ define Device/netgear_rax120v2
        NETGEAR_BOARD_ID := RAX120
        NETGEAR_HW_ID := 29765589+0+512+1024+4x4+8x8
        DEVICE_PACKAGES := ipq-wifi-netgear_rax120v2 kmod-spi-gpio \
-               kmod-spi-bitbang kmod-gpio-nxp-74hc164 kmod-hwmon-g761
+               kmod-spi-bitbang kmod-gpio-nxp-74hc164 kmod-hwmon-g762
        IMAGES += web-ui-factory.img
        IMAGE/web-ui-factory.img := append-image initramfs-uImage.itb | \
                pad-offset $$$$(BLOCKSIZE) 64 | append-uImage-fakehdr filesystem | \