projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1895d55
)
kernel: the camellia module name has changed in kernel 3.4
author
Florian Fainelli
<florian@openwrt.org>
Wed, 24 Oct 2012 13:04:54 +0000
(13:04 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Wed, 24 Oct 2012 13:04:54 +0000
(13:04 +0000)
With the support for architecture optimized camellia routines, the original
camellia module got renamed to camellia_generic, account for that.
SVN-Revision: 33903
package/kernel/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/crypto.mk
b/package/kernel/modules/crypto.mk
index 984ccc1f9b036f260075bae89673b6bcb9c773b9..43a7cc3431416d1fe486d64366f4629bf4df44d4 100644
(file)
--- a/
package/kernel/modules/crypto.mk
+++ b/
package/kernel/modules/crypto.mk
@@
-324,6
+324,9
@@
endef
$(eval $(call KernelPackage,crypto-sha1))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
+camellia_mod_suffix=_generic
+endif
define KernelPackage/crypto-misc
TITLE:=Other CryptoAPI modules
@@
-347,7
+350,7
@@
define KernelPackage/crypto-misc
CONFIG_CRYPTO_WP512
FILES:= \
$(LINUX_DIR)/crypto/anubis.ko \
- $(LINUX_DIR)/crypto/camellia.ko \
+ $(LINUX_DIR)/crypto/camellia
$(camellia_mod_suffix)
.ko \
$(LINUX_DIR)/crypto/cast5.ko \
$(LINUX_DIR)/crypto/cast6.ko \
$(LINUX_DIR)/crypto/fcrypt.ko \