build: create package index.json
authorEric Fahlgren <ericfahlgren@gmail.com>
Tue, 12 Nov 2024 17:10:02 +0000 (09:10 -0800)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 12 Nov 2024 17:34:51 +0000 (18:34 +0100)
Duplicate the old opkg index.json using the new apk database.
Needed to get the ASU server working on new snapshots.

Signed-off-by: Eric Fahlgren <ericfahlgren@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16931
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/Makefile

index b60ed10fb6d87d21611c79ec4e1da996ef407c8d..88d312d4edc56d223af043a94863150205340dc4 100644 (file)
@@ -131,6 +131,11 @@ ifneq ($(CONFIG_USE_APK),)
                        --sign $(BUILD_KEY_APK_SEC) \
                        --output packages.adb \
                        $$(ls *.apk | grep -v 'base-files-\|kernel-\|libc-'); \
+               echo -n '{"architecture": "$(ARCH_PACKAGES)", "packages":{' > index.json; \
+               $(STAGING_DIR_HOST)/bin/apk adbdump packages.adb | \
+                       awk '/- name: / {pkg = $$NF} ; / version: / {printf "\"%s\": \"%s\", ", pkg, $$NF}' | \
+                       sed 's/, $$//' >> index.json; \
+               echo '}}' >> index.json; \
        done
 else
        @for d in $(PACKAGE_SUBDIRS); do ( \