projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
34fcd83
)
kernel/usb-net-rtl8152: fix missing dependency
author
Mieczyslaw Nalewaj
<namiltd@yahoo.com>
Tue, 26 Nov 2024 12:37:21 +0000
(13:37 +0100)
committer
Zoltan HERPAI
<wigyori@uid0.hu>
Tue, 17 Dec 2024 22:28:11 +0000
(23:28 +0100)
Fix missing dependency on kernel 6.12.
Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
package/kernel/linux/modules/usb.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/usb.mk
b/package/kernel/linux/modules/usb.mk
index 734df050cd6cdc25ceec309471ae60f27874855c..6b82e03b9785abe00acc6ce0eb7d56d144801155 100644
(file)
--- a/
package/kernel/linux/modules/usb.mk
+++ b/
package/kernel/linux/modules/usb.mk
@@
-1435,7
+1435,7
@@
$(eval $(call KernelPackage,usb-net-rtl8150))
define KernelPackage/usb-net-rtl8152
TITLE:=Kernel module for USB-to-Ethernet Realtek convertors
- DEPENDS:=+r8152-firmware +kmod-crypto-sha256 +kmod-usb-net-cdc-ncm
+ DEPENDS:=+r8152-firmware +kmod-crypto-sha256 +kmod-usb-net-cdc-ncm
+LINUX_6_12:kmod-libphy
KCONFIG:=CONFIG_USB_RTL8152
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/r8152.ko
AUTOLOAD:=$(call AutoProbe,r8152)