compat-wireless: refresh patches
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 27 Sep 2010 18:43:42 +0000 (11:43 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 27 Sep 2010 18:43:42 +0000 (11:43 -0700)
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
patches/03-rfkill.patch
patches/04-netns.patch
patches/10-add-wext-handlers-to-netdev.patch
patches/14-device-type.patch
patches/15-symbol-export-conflicts.patch
patches/25-multicast-list_head.patch
patches/28-pm-qos-params.patch
patches/35-backport-brcm80211-Makefile.patch

index 2b8ee94e749e37e3cb553fa8abc32bbbd01f4364..b1b2babc3c9754156532908f4d056028c206ff45 100644 (file)
@@ -208,7 +208,7 @@ This would do the policing from within mac80211.
  #include <net/cfg80211.h>
 --- a/drivers/net/wireless/ath/ath9k/hw.c
 +++ b/drivers/net/wireless/ath/ath9k/hw.c
-@@ -1910,7 +1910,7 @@ int ath9k_hw_fill_cap_info(struct ath_hw
+@@ -1909,7 +1909,7 @@ int ath9k_hw_fill_cap_info(struct ath_hw
  
        pCap->hw_caps |= ATH9K_HW_CAP_ENHANCEDPM;
  
index 26e4afdef7f9bc9cedffa9092053b1e89337a52a..42f8a94c94e22ac322408f66781fcb14743c0fa0 100644 (file)
@@ -44,7 +44,7 @@ files...
  
  static void cfg80211_rfkill_poll(struct rfkill *rfkill, void *data)
  {
-@@ -376,7 +378,9 @@ struct wiphy *wiphy_new(const struct cfg
+@@ -381,7 +383,9 @@ struct wiphy *wiphy_new(const struct cfg
        rdev->wiphy.flags |= WIPHY_FLAG_PS_ON_BY_DEFAULT;
  #endif
  
@@ -54,7 +54,7 @@ files...
  
        rdev->rfkill_ops.set_block = cfg80211_rfkill_set_block;
        rdev->rfkill = rfkill_alloc(dev_name(&rdev->wiphy.dev),
-@@ -694,8 +698,10 @@ static int cfg80211_netdev_notifier_call
+@@ -699,8 +703,10 @@ static int cfg80211_netdev_notifier_call
                mutex_lock(&rdev->devlist_mtx);
                list_add_rcu(&wdev->list, &rdev->netdev_list);
                rdev->devlist_generation++;
@@ -65,7 +65,7 @@ files...
  
                if (sysfs_create_link(&dev->dev.kobj, &rdev->wiphy.dev.kobj,
                                      "phy80211")) {
-@@ -841,6 +847,7 @@ static struct notifier_block cfg80211_ne
+@@ -846,6 +852,7 @@ static struct notifier_block cfg80211_ne
        .notifier_call = cfg80211_netdev_notifier_call,
  };
  
@@ -73,7 +73,7 @@ files...
  static void __net_exit cfg80211_pernet_exit(struct net *net)
  {
        struct cfg80211_registered_device *rdev;
-@@ -858,14 +865,17 @@ static void __net_exit cfg80211_pernet_e
+@@ -863,14 +870,17 @@ static void __net_exit cfg80211_pernet_e
  static struct pernet_operations cfg80211_pernet_ops = {
        .exit = cfg80211_pernet_exit,
  };
@@ -91,7 +91,7 @@ files...
  
        err = wiphy_sysfs_init();
        if (err)
-@@ -900,8 +910,10 @@ out_fail_nl80211:
+@@ -905,8 +915,10 @@ out_fail_nl80211:
  out_fail_notifier:
        wiphy_sysfs_exit();
  out_fail_sysfs:
@@ -102,7 +102,7 @@ files...
        return err;
  }
  subsys_initcall(cfg80211_init);
-@@ -913,7 +925,9 @@ static void __exit cfg80211_exit(void)
+@@ -918,7 +930,9 @@ static void __exit cfg80211_exit(void)
        unregister_netdevice_notifier(&cfg80211_netdev_notifier);
        wiphy_sysfs_exit();
        regulatory_exit();
index f0df25966a4795324a943111acd1da1d2f048e87..655d911b8e86aed414e00621cd3f9fdb83ad3c0c 100644 (file)
@@ -18,7 +18,7 @@ CONFIG_WIRELESS_EXT in compat-wireless.
 
 --- a/net/wireless/core.c
 +++ b/net/wireless/core.c
-@@ -366,10 +366,6 @@ struct wiphy *wiphy_new(const struct cfg
+@@ -371,10 +371,6 @@ struct wiphy *wiphy_new(const struct cfg
        INIT_LIST_HEAD(&rdev->bss_list);
        INIT_WORK(&rdev->scan_done_wk, __cfg80211_scan_done);
  
@@ -29,7 +29,7 @@ CONFIG_WIRELESS_EXT in compat-wireless.
        device_initialize(&rdev->wiphy.dev);
        rdev->wiphy.dev.class = &ieee80211_class;
        rdev->wiphy.dev.platform_data = rdev;
-@@ -712,6 +708,15 @@ static int cfg80211_netdev_notifier_call
+@@ -717,6 +713,15 @@ static int cfg80211_netdev_notifier_call
                wdev->sme_state = CFG80211_SME_IDLE;
                mutex_unlock(&rdev->devlist_mtx);
  #ifdef CONFIG_CFG80211_WEXT
index 0f36773f0b752542d949dea95b2ff0a698f080d3..0765ea3d043981923592e1c2adee83c04bf9b9af 100644 (file)
@@ -8,7 +8,7 @@ compile warning.
 
 --- a/net/wireless/core.c
 +++ b/net/wireless/core.c
-@@ -655,9 +655,11 @@ static void wdev_cleanup_work(struct wor
+@@ -660,9 +660,11 @@ static void wdev_cleanup_work(struct wor
        dev_put(wdev->netdev);
  }
  
index 509ff463b00050a234db74d74793d0f276c6b168..e7311c2cae23560be7b01e92560bf4183778ae2e 100644 (file)
@@ -3,7 +3,7 @@ To avoid conflicts with the other export we rename our.
 
 --- a/net/mac80211/rx.c
 +++ b/net/mac80211/rx.c
-@@ -2828,7 +2828,12 @@ void ieee80211_rx(struct ieee80211_hw *h
+@@ -2847,7 +2847,12 @@ void ieee80211_rx(struct ieee80211_hw *h
   drop:
        kfree_skb(skb);
  }
index 71b9c9d19d5d658f02da0f5328b152e54e8a3cec..37f7941f37da06e2586197f9637b11f487a563bb 100644 (file)
@@ -602,7 +602,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
        return hash.low | ((u64)hash.high << 32);
 --- a/include/net/mac80211.h
 +++ b/include/net/mac80211.h
-@@ -1713,7 +1713,11 @@ struct ieee80211_ops {
+@@ -1727,7 +1727,11 @@ struct ieee80211_ops {
                                 struct ieee80211_bss_conf *info,
                                 u32 changed);
        u64 (*prepare_multicast)(struct ieee80211_hw *hw,
@@ -663,7 +663,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
  
 --- a/net/mac80211/ieee80211_i.h
 +++ b/net/mac80211/ieee80211_i.h
-@@ -698,7 +698,12 @@ struct ieee80211_local {
+@@ -723,7 +723,12 @@ struct ieee80211_local {
        struct work_struct recalc_smps;
  
        /* aggregated multicast list */
index b068097b292b426a5c4d4c6cf832f842e88dbab9..1521237d324d683404ea88b9a3c8a696cf81086f 100644 (file)
@@ -104,7 +104,7 @@ little wierd.
                                        found->vif.bss_conf.beacon_int);
 --- a/net/mac80211/scan.c
 +++ b/net/mac80211/scan.c
-@@ -512,7 +512,11 @@ static int ieee80211_scan_state_decision
+@@ -513,7 +513,11 @@ static int ieee80211_scan_state_decision
                bad_latency = time_after(jiffies +
                                ieee80211_scan_get_channel_time(next_chan),
                                local->leave_oper_channel_time +
index 7cafbfb257e762c2bb285718d34ce5e6c241de6f..ee15121bf34e45b7968ad949c8f70ecd5f2f58b9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/staging/brcm80211/Makefile
 +++ b/drivers/staging/brcm80211/Makefile
-@@ -24,10 +24,10 @@
+@@ -24,10 +24,10 @@ ccflags-y :=                                       \
        -DDBAND                                 \
        -DBCMDMA32                              \
        -DBCMNVRAMR                             \