kernel: usb: improve support for ath79 target
authorShiji Yang <yangshiji66@qq.com>
Fri, 13 Sep 2024 11:52:30 +0000 (19:52 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Sep 2024 21:58:47 +0000 (23:58 +0200)
1. Remove outdated symbol CONFIG_USB_OHCI_ATH79.
The ath79 OHCI USB was already supported by the generic driver
kmod-usb-ohci. And this kernel symbol has been dropped since
upstream commit:
53d473fc1e38 ("usb: host: Remove the deprecated ATH79 USB host config options")

2. Add ath79 USB phy package to the OHCI dependencies.
Both EHCI and OHCI require it on the ath79 target.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Link: https://github.com/openwrt/openwrt/pull/16380
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/usb.mk

index 7172bdf502375f8806b87abdfe6557eb54eec855..458c8c4ba68f8626f0a4bcc62a8b5d0d8b03aceb 100644 (file)
@@ -272,13 +272,13 @@ $(eval $(call KernelPackage,usb-uhci,1))
 define KernelPackage/usb-ohci
   TITLE:=Support for OHCI controllers
   DEPENDS:= \
+       +TARGET_ath79:kmod-phy-ath79-usb \
        +TARGET_bcm53xx:kmod-usb-bcma \
        +TARGET_bcm47xx:kmod-usb-bcma \
        +TARGET_bcm47xx:kmod-usb-ssb
   KCONFIG:= \
        CONFIG_USB_OHCI \
        CONFIG_USB_OHCI_HCD \
-       CONFIG_USB_OHCI_ATH79=y \
        CONFIG_USB_OHCI_HCD_AT91=y \
        CONFIG_USB_OHCI_BCM63XX=y \
        CONFIG_USB_OCTEON_OHCI=y \