projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
40d5825
)
fix ccache build order
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 14 Dec 2006 05:10:23 +0000
(
05:10
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 14 Dec 2006 05:10:23 +0000
(
05:10
+0000)
SVN-Revision: 5783
toolchain/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/Makefile
b/toolchain/Makefile
index ceae2269a6c82f4c1ae6d06205d8a567cde10101..4682dbed17b696de08dbecba16e670c200c618dc 100644
(file)
--- a/
toolchain/Makefile
+++ b/
toolchain/Makefile
@@
-25,7
+25,10
@@
install: $(TARGETS_INSTALL)
clean: $(TARGETS_CLEAN)
$(TARGETS_INSTALL): $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
-uClibc-prepare: ccache-prepare kernel-headers-prepare
+ifeq ($(CONFIG_CCACHE),y)
+ uClibc-prepare: ccache-install
+endif
+uClibc-prepare: kernel-headers-prepare
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
binutils-prepare: uClibc-prepare
gcc-prepare: binutils-install