projects
/
openwrt
/
staging
/
noltari.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6ea49c5
)
kernel: make hwmon-lm75 only depend on kmod-thermal if needed
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 14 Sep 2014 12:06:38 +0000
(12:06 +0000)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 14 Sep 2014 12:06:38 +0000
(12:06 +0000)
This fixes commit r42529 and closes #17855.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 42531
package/kernel/linux/modules/hwmon.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/hwmon.mk
b/package/kernel/linux/modules/hwmon.mk
index 90f2197aa9789927858e33031d679b95f2171b15..ad0ef2dd4ef27950f36d4462b72ea53fe964b449 100644
(file)
--- a/
package/kernel/linux/modules/hwmon.mk
+++ b/
package/kernel/linux/modules/hwmon.mk
@@
-119,7
+119,7
@@
define KernelPackage/hwmon-lm75
KCONFIG:=CONFIG_SENSORS_LM75
FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.ko
AUTOLOAD:=$(call AutoProbe,lm75)
- $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
+ $(call AddDepends/hwmon,+kmod-i2c-core +
PACKAGE_kmod-thermal:
kmod-thermal)
endef
define KernelPackage/hwmon-lm75/description