projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1978c07
)
add and export HOSTCC_NOCACHE
author
John Crispin
<john@openwrt.org>
Wed, 20 Jun 2012 07:48:47 +0000
(07:48 +0000)
committer
John Crispin
<john@openwrt.org>
Wed, 20 Jun 2012 07:48:47 +0000
(07:48 +0000)
SVN-Revision: 32466
rules.mk
patch
|
blob
|
history
diff --git
a/rules.mk
b/rules.mk
index 83bc6221669375c97251739829d1aa0576716134..412615c3203b0224e68ab4239c6e1f6f39b5e5b3 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-188,8
+188,10
@@
INSTALL_CONF:=install -m0600
ifneq ($(CONFIG_CCACHE),)
TARGET_CC_NOCACHE:=$(TARGET_CC)
TARGET_CXX_NOCACHE:=$(TARGET_CXX)
+ HOSTCC_NOCACHE:=$(HOSTCC)
export TARGET_CC_NOCACHE
export TARGET_CXX_NOCACHE
+ export HOSTCC_NOCACHE
TARGET_CC:= ccache_cc
TARGET_CXX:= ccache_cxx
HOSTCC:= ccache $(HOSTCC)