projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
937347a
)
s390/boot: pad bzImage to 4K
author
Martin Schwidefsky
<schwidefsky@de.ibm.com>
Wed, 17 Apr 2019 14:32:27 +0000
(16:32 +0200)
committer
Martin Schwidefsky
<schwidefsky@de.ibm.com>
Fri, 26 Apr 2019 10:34:05 +0000
(12:34 +0200)
In order to be able to sign the bzImage independent of the block size
of the IPL device, align the bzImage to 4096 bytes.
Signed-off-by: Martin Schwidefsky <schwidefsky@de.ibm.com>
arch/s390/boot/Makefile
patch
|
blob
|
history
diff --git
a/arch/s390/boot/Makefile
b/arch/s390/boot/Makefile
index 1f8fd68beae382278ef5d884ca0e0e6f6ad9f81f..c1993c57300fba9a5490b2ba2cfc162107628530 100644
(file)
--- a/
arch/s390/boot/Makefile
+++ b/
arch/s390/boot/Makefile
@@
-50,6
+50,7
@@
define cmd_section_cmp
touch $@
endef
+OBJCOPYFLAGS_bzImage := --pad-to $$(readelf -s $(obj)/compressed/vmlinux | awk '/\<_end\>/ {print or(strtonum("0x"$$2),4095)+1}')
$(obj)/bzImage: $(obj)/compressed/vmlinux $(obj)/section_cmp.boot.data $(obj)/section_cmp.boot.preserved.data FORCE
$(call if_changed,objcopy)