projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
42f0ab0
)
build: add gzip to prereq-build.mk
author
Tony Butler
<spudz76@gmail.com>
Fri, 2 Dec 2022 20:05:08 +0000
(12:05 -0800)
committer
Christian Marangi
<ansuelsmth@gmail.com>
Tue, 6 Dec 2022 22:53:45 +0000
(23:53 +0100)
gzip has never been checked for, a system without it would be rare, fix
it anyway
Signed-off-by: Tony Butler <spudz76@gmail.com>
include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/include/prereq-build.mk
b/include/prereq-build.mk
index c5c2f1c8bb4f64dae4ba9ce464bd1f30e0e75f24..9c4ef547ad04d28bf5f24e4a4791cc2efdb2ae6b 100644
(file)
--- a/
include/prereq-build.mk
+++ b/
include/prereq-build.mk
@@
-149,6
+149,9
@@
$(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
gstat -c%s $(TOPDIR)/Makefile, \
stat -c%s $(TOPDIR)/Makefile))
+$(eval $(call SetupHostCommand,gzip,Please install 'gzip', \
+ gzip --version </dev/null))
+
$(eval $(call SetupHostCommand,unzip,Please install 'unzip', \
unzip 2>&1 | grep zipfile, \
unzip))