projects
/
openwrt
/
staging
/
lynxis
/
omap.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d5ee23e
)
kernel: fix duplicate drivers for the PC speaker in one package
author
Felix Fietkau
<nbd@nbd.name>
Sun, 3 Jul 2016 17:35:42 +0000
(19:35 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Sun, 3 Jul 2016 17:35:43 +0000
(19:35 +0200)
Only use the ALSA capable one, it supports regular beeps as well
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/sound.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/sound.mk
b/package/kernel/linux/modules/sound.mk
index d09cf21abac30a1353a51ae3269dff023639d1ce..52a44d6a8a7601b0ec2edde61bdc251dd21bffa4 100644
(file)
--- a/
package/kernel/linux/modules/sound.mk
+++ b/
package/kernel/linux/modules/sound.mk
@@
-259,12
+259,10
@@
define KernelPackage/pcspkr
DEPENDS:=@TARGET_x86 +kmod-input-core
TITLE:=PC speaker support
KCONFIG:= \
- CONFIG_INPUT_PCSPKR \
CONFIG_SND_PCSP
FILES:= \
- $(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
$(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
- AUTOLOAD:=$(call AutoLoad,50,
pcspkr
snd-pcsp)
+ AUTOLOAD:=$(call AutoLoad,50,snd-pcsp)
$(call AddDepends/sound)
endef