include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
-PKG_VERSION:=2.38
+PKG_VERSION:=2.39
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=ab066a97c226066485ad20e5ad5ce424
+PKG_MD5SUM:=1ffccc1f0d9b8a08f2b99e03ba9cc08b
include $(INCLUDE_DIR)/package.mk
-Index: dnsmasq-2.38/src/config.h
+Index: dnsmasq-2.39/src/config.h
===================================================================
---- dnsmasq-2.38.orig/src/config.h 2007-06-04 13:22:23.553274640 +0200
-+++ dnsmasq-2.38/src/config.h 2007-06-04 13:22:23.626263544 +0200
-@@ -280,8 +280,9 @@
+--- dnsmasq-2.39.orig/src/config.h 2007-06-26 19:16:31.000000000 +0200
++++ dnsmasq-2.39/src/config.h 2007-06-26 19:16:31.000000000 +0200
+@@ -281,8 +281,9 @@
/* We assume that systems which don't have IPv6
headers don't have ntop and pton either */
-Index: dnsmasq-2.38/src/netlink.c
+Index: dnsmasq-2.39/src/netlink.c
===================================================================
---- dnsmasq-2.38.orig/src/netlink.c 2007-06-04 13:22:23.531277984 +0200
-+++ dnsmasq-2.38/src/netlink.c 2007-06-04 13:22:23.814234968 +0200
+--- dnsmasq-2.39.orig/src/netlink.c 2007-06-26 19:16:31.000000000 +0200
++++ dnsmasq-2.39/src/netlink.c 2007-06-26 19:16:31.000000000 +0200
@@ -17,6 +17,10 @@
#include <linux/types.h>
#include <linux/netlink.h>
+++ /dev/null
-Index: dnsmasq-2.38/src/cache.c
-===================================================================
---- dnsmasq-2.38.orig/src/cache.c 2007-06-04 13:22:23.510281176 +0200
-+++ dnsmasq-2.38/src/cache.c 2007-06-04 13:22:24.014204568 +0200
-@@ -749,10 +749,11 @@
- while ((token = strtok(NULL, " \t\n\r")) && (*token != '#'))
- {
- struct crec *cache;
-+ int fqdn = !!strchr(token, '.');
- if (canonicalise(token))
- {
- /* If set, add a version of the name with a default domain appended */
-- if ((opts & OPT_EXPAND) && domain_suffix && !strchr(token, '.') &&
-+ if ((opts & OPT_EXPAND) && domain_suffix && !fqdn &&
- (cache = malloc(sizeof(struct crec) +
- strlen(token)+2+strlen(domain_suffix)-SMALLDNAME)))
- {