projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
50817f6
)
kernel: remove kmod-input-core just for some x86 profiles.
author
Hauke Mehrtens
<hauke@hauke-m.de>
Mon, 15 Aug 2011 11:05:35 +0000
(11:05 +0000)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Mon, 15 Aug 2011 11:05:35 +0000
(11:05 +0000)
Not all x86 profiles have CONFIG_INPUT=y in their configuration. Just remove kmod-input-core for them.
Thank you Philip Prindeville for pointing out this problem.
SVN-Revision: 27988
package/kernel/modules/001-depends.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/001-depends.mk
b/package/kernel/modules/001-depends.mk
index 602775c0157a5a0e0ac187005914fd84b17bc7c1..238799e2e54c6d4dcd469598e203d8f36e187986 100644
(file)
--- a/
package/kernel/modules/001-depends.mk
+++ b/
package/kernel/modules/001-depends.mk
@@
-27,11
+27,11
@@
endef
define SetDepends/input
- DEPENDS:= @!
TARGET_x86
+ DEPENDS:= @!
(TARGET_x86_generic||TARGET_x86_kvm_guest)
endef
define AddDepends/input
- DEPENDS+= +!
TARGET_x86
:kmod-input-core $(1)
+ DEPENDS+= +!
(TARGET_x86_generic||TARGET_x86_kvm_guest)
:kmod-input-core $(1)
endef