projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
10ef67e
)
kernel: make sure that packages are generated for built-in crypto modules to avoid...
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 14 Jan 2013 17:09:16 +0000
(17:09 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 14 Jan 2013 17:09:16 +0000
(17:09 +0000)
SVN-Revision: 35158
package/kernel/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/crypto.mk
b/package/kernel/modules/crypto.mk
index 221b5a0e4ebd3ac68ac09eb2827bce91e947d0dc..6a3b5a6bae3ed772dd5c5e75636a11c44fc6c454 100644
(file)
--- a/
package/kernel/modules/crypto.mk
+++ b/
package/kernel/modules/crypto.mk
@@
-15,7
+15,7
@@
CRYPTOMGR_MODULES = \
BLKCIPHER2=crypto_blkcipher
crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
-crypto_file=$(
if $(findstring y,$($(call crypto_confvar,$(1)))),,$(LINUX_DIR)/crypto/$(word 2,$(subst =,$(space),$(1))).ko)
+crypto_file=$(
LINUX_DIR)/crypto/$(word 2,$(subst =,$(space),$(1))).ko
crypto_name=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(word 2,$(subst =,$(space),$(1))))
define KernelPackage/crypto-core