add 'OpenWrt-1.0' to gcc version info
authorFelix Fietkau <nbd@openwrt.org>
Fri, 27 Jan 2006 18:50:59 +0000 (18:50 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 27 Jan 2006 18:50:59 +0000 (18:50 +0000)
SVN-Revision: 3057

openwrt/toolchain/gcc/Makefile

index f6f4acaab63cc067a5b68ecb4e04703b507a1a91..1d7c8650ff5ff93d00b2aaf197144375061ffbb1 100644 (file)
@@ -79,6 +79,8 @@ ifeq ("$(strip $(ARCH))","armeb")
        $(SCRIPT_DIR)/patch-kernel.sh $(GCC_DIR) ./$(GCC_VERSION) arm-softfloat.patch.conditional
 endif
 endif
+       $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-1.0)\2,' $(GCC_DIR)/gcc/version.c
+       $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(GCC_DIR)/gcc/version.c
        touch $(GCC_DIR)/.patched
 
 # The --without-headers option stopped working with gcc 3.0 and has never been